Neues Speichersystem mit LiFePo und Victron Wechselrichter(n)

  • Sodele der Cerbo läuft mittlerweile und hat auch einen SSH / root Zugang bekommen. Stromversorgung läuft über die Lynx also 48+V und einem DC-DC Spannungswandler auf 12V. Theoretisch sollte es ohne den Wandler gehen, aber Victron hat ein paar Serien gebaut, die bei Einschalten mit 60V hopps gehen - also sicher ist sicher.
    Ich habe aktuell noch keine Batterie dran, aber die MPII erzeugen ja 54+V wenn nichts dranhängt - so darf man natürlich kein FW upgrade der MPII machen, da ansonsten der Cerbo während des Upgrades keinen Strom mehr bekommt und das geht dann voll in die Hose.

    Der Lynx Shunt wird auch erkannt, allerdings ging das mit dem original Victron Kabel nicht - habe dann ein 08/15 Netzwerkkabel genommen und damit ging es auf anhieb - strange - aber gut.

    Dann auch gleich mal den Paketmanager, Shutdown;Monitor und den BatterieAgregator installiert.

     

    Da noch keine seriellen BMS angeschlossen sind, wird hier der Lynx Shunt noch als Input genommen.

    Nun auch wieder die MQTT BalkonPV installiert

    cd /tmp
    wget -O /tmp/venus-os_dbus-mqtt-pv.zip https://github.com/mr-manuel/venus-os_dbus-mqtt-pv/archive/refs/heads/master.zip
    unzip venus-os_dbus-mqtt-pv.zip
    cp -R /tmp/venus-os_dbus-mqtt-pv-master/dbus-mqtt-pv/ /data/etc/
    cp /data/etc/dbus-mqtt-pv/config.sample.ini /data/etc/dbus-mqtt-pv/config.ini
    nano /data/etc/dbus-mqtt-pv/config.ini

    nachdem die Konfig passt als Service installieren

    bash /data/etc/dbus-mqtt-pv/install.sh

    und prüfen ob alles passt mit

    tail -n 100 -f /data/log/dbus-mqtt-pv/current | tai64nlocal
    svstat /service/dbus-mqtt-pv

     

    Wenn man die Devices sortieren möchte muss man leider mit den Anfangsbuchstaben "spielen" (rechtes Bild)

    Ach ja: Node Red - geht super einfach mit Export auf dem Raspi dann import auf dem Cerbo - deploy und fertig alles geht wie auf dem Raspi (vorrausgesetzt man hat die evtl. fehlenden Module schon installiert).

    Update:
    Warum auch immer fliegt jetzt die Sicherung der MPII (32A Sicherung und sogar die 40A Vorsicherung) vorher blitzt kurz die Overload LED am MPII auf. Das soll durch die Vorladung der Kondensatoren kommen (beim Einschalten). Komischerweise hat das ja x mal vorher geklappt und der erste Abbruch ist im Betrieb passiert (sprich die MPII liefen schon eine Weile). Jetzt ist es halt so wie dokumentiert ohne Batterie geht nix - leider befürchte ich ist meine Bestellung noch ein paar Wochen unterwegs. Nicht so schlimm ohne Batterie machen die MPII ja auch nicht wirklich Sinn - vermutlich ging es vorher weil die Kondensatoren noch von der Einstellaktion (DC Seitig mit Ladegerät verbunden) geladen waren. Von daher probiert es besser nicht ohne Batterie, nichts das noch etwas kaputt geht.

  •    

    Heute kam eine erste Lieferung EEL Box V3. Soweit so gut. Auf den ersten Blick ist das PCB alt (nur eine Lane für Balancer und BMS) und es fehlt (noch) BMS + 4A Active Balancer.

       

    Box mit Teilen liegt dabei (in der Kiste) und ausgepackt das Zeuchs rechts - sprich distanz/trennplatten und Montagematerial + Busbars.
    Die Verabeitung sieht sehr gut aus.

    Ich geh mal davon aus, das BMS und balancer noch getrennt kommt - bzgl PCB werde ich Nachlieferung fordern. Wenn das Datum auf dem Karton stimmt, wundert es micht nicht, das hier das alte PCB drin ist 10.2023 gab es das noch nicht (meines Wissens).

    Update 1:
    Aha, laut Tracking kam das Paket aus Polen - also wohl die zweite Kiste die ich in der EU bestellt habe (nicht auf Alibaba). Auf der Webseite steht auch:

    Quote

    Hinweis 1: Der Balancer muss an die Batteriezellen angeschlossen werden, NICHT an Leiterplatten
    Hinweis 2: Das BMS und der Balancer werden separat aus China versendet.

    D.h. das klärt dann auch das alte PCB - kann ich mich wohl nicht beschweren. Das aus China sollte dann das neue Design haben.

    Update 2:
    Alles mal zusammengeschraubt soweit das ohne BMS... Sinn macht. Passt alles gut und ist stabil. Nur eine Schraube für das Frontterminal scheint ein versautes Gewinde zu haben - muss ich nachschneiden oder ersetzen :(

    DHL Expressverlauf:
    Ich hoffe mal BMS und Balancer aus China kommt auch zügig und nicht erst in x Monaten. Leider habe ich keinen Tracking code bekommen (auch wenn die Verfolgung etwas anderes behauptet).

  •  

    Griffe und Terminals montiert. Die chromfarbenen Schnapper sind zum Verspannen von gestapelten Boxen.
    In die Löcher an den Ecken passen die Füsse am Boden, so dass die Boxen sicher aufeinander stehen.

    • New
    • Official Post

    Gerade kamen weitere Pakete diesmal aus meine China Bestellung

       

    Die Rollunterlage, macht einen superstabilen Eindruck

     

    Die Box selber diesmal mit dem neuen PCB welches zwei getrennte Leiterbahnen hat und Anschluss für aktiven Balancer

            

    Active Balancer und das Seplos BMS + Heizmatten (die ich vermutlich nie verwenden werde)

       

    Die Zellen - gleich mal getestet ob die Pole halten - aber kein Problem an allen 16 Zellen

    Falls ich es noch nicht geschrieben habe die zweite Bestellung Zellen habe ich über https://www.nkon.nl/de/eve-lf304-p…2v-a-grade.html geordert.

    • New
    • Official Post

    Erste Messung der Zellen. Widerstände alle 100% identisch bei 0.2mOhm. Spannung 8 tausendstel auseinander. Zelle 6 fällt etwas ab.
    Muss mir noch ein Android Mobile besorgen um die QR Codes mit einer passenden App auszulesen.

    Zum Messen wurde der YR1035 benutzt.

    Messungen26.04.2024
    ZelleWiderstand mOhmSpannung V
    10,203,2944
    20,203,2944
    30,203,2943
    40,203,2944
    50,203,2944
    60,203,2938
    70,203,2944
    80,203,2945
    90,203,2945
    100,203,2946
    110,203,2944
    120,203,2946
    130,203,2945
    140,203,2942
    150,203,2943
    160,203,2942
    • New
    • Official Post

    Heute mal die eine Box weiter vorbereitet und das BMS eingebaut.

     

    Dei Schaumstoffbahnen von unten auf die PCB kleben (hmm das kann man auch später machen :)), Sicherungshalter, BMS und LCD einbauen

     

    Beim BMS und LCD aufpassen, das alles gut durch die öffnungen passt. Nur die DIP schalter sehen etwas schräg aus, das ist aber so. Beim LCD drauf achten, das die Knöpfer leicht gehen und der Druckpunkt fühlbar ist (evtl. die Knöpfe mal hin und her wechseln)

       

    Die Sicherung und die Verbinder einbauen. Erst locker an den Terminals anschrauben dann an der Sicherung. So rum ging es bei mir einfacher

       

    Als letztes die Verbinder zum Shunt und Polen von der Batterie. Minus auf Shunt so "einstellen" das der Verbinder nicht auf dem BMS aufliegt.

    Die Kabel von LCD uns Schalter habe ich mit etwas Elektroklebeband fixiert.

    • New
    • Official Post

    Das zweite BMS ist eingetroffen (von der älteren Version). Einziger Unterschied ist Plus Batterieanschlusskabel ist anders. Evtl. ist das LED Anschlusskabel einen Ticken kürzer.

    Und ich habe angefangen die schon gelieferten Batterien zu testen:

       

    Der "übliche" ZKETECH in Aktion. Zelle leicht eingespannt - hat übrigens keinen Bauch eher sogar nach innen gewölbt.

    Wenn ich die erste Zelle durch habe stelle ich mal das Protokoll ein. Wird maximal eine Zelle pro Tag durchlaufen. Ich werde aber nur die Discharge Kapazität messen, sonst dauert das zu lange und bringt nicht wirklich großen Mehrwert. Evt. mach ich einmal beides um den Kurvenverlauf komplett zu haben.

    • New
    • Official Post

    Grumble - jetzt hat doch der olle Laptop in der Nacht einen Reboot gemacht (Sicherheitsupdates) :( Messkurven sind also weg. Immerhin, der Tester hat nach dem Entladen gestoppt und 311Ah bei Zelle 01-01 gemessen.

    Ungewollt das hier nachgetestet:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    und dann einfach noch ein Video zum Tester

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    und eines in DE wo er benutzt wird:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Update: Zelle 01-02 hat 310,9Ah (das ist ~1kWh) allerding nur von 3.60 bis 2.55V entladen, die erste Zelle war von 3.65 bis 2.5V. Werde noch ein paar Zellen messen und dann die Kurven und Einstellungen posten.

    • New
    • Official Post

    Mal Beispielhaft die Messkurve von Pack 01 Zelle 02:

    Rechts mitte sieht man die Schritte die durchlaufen wurden:

    1. Constant Voltage Charging auf 3,6V mit 40A dann warten bis die Stromstärke auf 3A gefallen ist
    2. 30min warten
    3. Constant Current Discharge mit 40A bis die Spannung 2.55V erreicht hat.
    4. Constant Voltage Charging auf 3,3V mit 40A dann warten bis 4 A erreicht sind.

    Ingesamt hat das ca. 16 Stunden gedauert. Das Entladen von ~5,5h-~13h also etwas weniger als 8h.

    Rechts oben dann die gemesse Kapazität und Energie pro Step:

    1. 194Ah oder 661Wh beim Laden bis Ladeschluss
    2. nix - logo wartet ja nur
    3. 310,6Ah oder 1005Wh Energie von voll auf leer entnommen (D-CC)
    4. dann wieder 234Wh reingeladen also ca. 23% voll.
    • New
    • Official Post

    6 Zellen durchgemessen - einen Ausreißer bisher, aber nach oben hin. Zelle 6 hatte die niedrigste Spannung, laut QR Code am gleichen Tag produziert aber offensichtlich etwas bessere Chemie erwischt oder was auch immer.

    • New
    • Official Post

    kleiner Zwischenstand der Messungen - zwei Zellen fehlen noch:

    Spitzenreiter ist jetzt Zelle 13 mit 313Ah. Vermutlich werde ich das Pack nächsten Samstag in Betrieb nehmen (sofern EInbau der Zellen klappt und BMS das tut was es soll).

    • New
    • Official Post

    Messungen done und Batterien mal in die Box verfrachtet.

    Hoffe die Reihenfolge der Zellen passt zur BMS Zellnummerierung.
    Bei Zelle 16 ist komischerweise Ah und Wh nicht passend

    Ach ja und die Orientierung der Zellen stimmt so nat. nicht, jede zweite muss noch gedreht werden. Auch muss ich noch etwas Material zwischen die Zellen bringen, damit ich diese später besser verspannen kann.

    • New
    • Official Post

    Sodele Zellverbinder sind drauf - handfest, dann kann sich das noch etwas setzen.

     

    Immer schön den Bereich an dem man nicht arbeitet abdecken. Die Pole habe ich mit Kontaktpaste bestrichen, bevor die Busbars drauf kamen. Das Pack hat 52.8V sollte ca. 23% geladen sein ~71Ah von ~310Ah voll. Zwischen die Zellen habe ich die dünnen glatten Trennplatten gelegt. am BMS Ende dann so viele weichere Schaumplatten, das ein leichter Anpressdruck beim verspannen entsteht, so dass sich die Zellen nicht mehr bewegen lassen. Die berühmten 300kg kann ich eh nicht messen, wird schon passen.

    Bzgl. Sicherheit den hinteren, mittleren Verbinder beider Seiten erstmal weglassen, damit man möglichst lange bei ungefährlichen <30V bleibt. Erst wenn das BMS final drin ist und in Betrieb gehen soll, den Verbinder einsetzen.

    • New
    • Official Post

    Moin,

    Zellen sind angeschlossen - BMS läuft.

       

    Also bei nicht bauchigen Zellen auf jeden Fall die Schaumstoffplatten einsetzen. Ich habe ja nur die harten, dünnen Platten drin. Konsequenz der Abstand der Notfallausblasöffnungen der Zellen passt nicht mehr 100% mit dem PCB.
    Wenn das Display schwarz bleibt mal Enter drücken und den Stecker kontrollieren, meiner hat einen Wackler muss ich wohl mit (Heiß)kleber fest machen. Dann mit dem passenden COM port und Rate 19200 verbinden. Login mit admin admin und Display einschalten (bis dahin kommt sonst abnormal Communication). Danach noch aktuellen SOC + Kapazität einstellen bzw. die aktuellen Ah sonst steht das auf vermutlich 50% und 100Ah von 200Ah.

    BMS und Balancer habe ich mit einer Schraube angeschlossen (sind nicht genügend dabei um die getrennt anzuschließen).

    Anmerkung zum Neey Balancer:
    Die Apps sind zum k.tzen. Entweder findet er das Bluetooth device nicht, oder aber man kann sich erfolglos auf den Kopf stellen um von chinesisch auf englisch umzustellen. Ich habe drei Versionen auf Android probiert (und ja die apps immer fein neu gestartet) und eine auf IOS. Teils ist sogar der Hersteller nicht Neey (obwohl es Neey vertreibt) wirklich komplett unprofessionell.
    Am Ende habe ich die Android Version aus den Google Shop verwendet (Version 1.x) und mit zweitem Mobile und online kamaera google-translate den Balancer eingestellt.

    • New
    • Official Post

    DIP Switches on the Seplos BMS Frontpanel - einmal das hier anschauen (english). Mal schauen ob ich das brauche sobald meine anderen Akkus eintreffen und gebaut sind.
    Frage ist nun schließt man alle je mit einen Seriellen port and Victron und dem Managementcomputer an, oder nutzt man auf Victronseite den CAN und bundled die Seplos zu einem Mutlipack oder ?? Vermutlich werde ich wie schon weiter oben angedeutet alles nur seriell machen, da man dann auch andere System seriell zusätzlich einbinden kann. Nachteil ist, dass man auf dem Cerbo dann zusatzsoftware braucht (als SerielBus und Aggregator)

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Das hier ist bzgl. Seplos Parameter evtl. auch noch interessant:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    • New
    • Official Post

     

    Hab's nicht ausgehalten und musste die Abstände korrigieren :) nun sitzt jede Öffnung korrekt über den Ventilen der Zellen. Die Prozedur alle demontieren und wieder montieren hat ca. 2.5 Stunden gedauert. Ist Fummelkram und Kurzschluss will man ja nicht haben.

    Die eine Seite habe ich dann noch den QR Code gescant - leider die zwei von der anderen Seite die noch fehlten vergessen. Sieht aber so aus als wären akkes vom gleichen Tag und "Band" - von daher würde es mich stark wundern, wenn die zwei ausgerechnet ein anderes Datum hätten.

    • New
    • Official Post

    Gerade mal https://louisvdw.github.io/dbus-serialbattery/general/install installiert. Man könnte auch direkt CAN nehmen, aber wenn möglich nehme ich hier erstmal den seriellen Bus da später dann flexibler um auch andere BMS einzubinden (falls nötig).

     


    Erstmal ging nix, da ich dachte ich könnte den zweiten Seriellen Port für die Verbindung nehmen - ging aber nicht :( Nachdem ich das Kabel vom BMS monitoring Rechner genommen hatte ging es auf Anhieb. Zum Testen dann auch mal ein Ladegerät mit 800W angeschlossen

    So weit so gut also. Ich muss ich noch rausfinden ob nicht doch beides gleichzeitig möglich ist. Irgendwie doof wenn man immer umstecken muss.

    Ah update: Die Kabel kann man dran lassen, aber es funktioniert immer nur ein Monitoring - sobald man die Monitoringsoftware am PC deaktiviert - kommen die Daten im Cerbo an. Damit kann ich leben.

    Der Batterieaggregator funktioniert auch - OK witzlos wenn man nur bisher ein Pack hat.

     

    Batterie bei 15A alles OK, nicht wird warm, unten meine Füße als Referenz und die Hotspots sind eher durch Reflektion der Busbars verursacht.
    Max temp knapp über 20C (gemessen mit Sensoren)

    Anmerkung zur PV-Leistung weil zufällig gerade zu sehen: Die Nordseite ist zwar doppelt so groß als Süd produziert aber in den Abendstunden 5+mal soviel Energie - und das obwohl die Anlage saudreckig ist.

    • New
    • Official Post

    Interessant finde ich noch wo denn nu die Stromstärke herkommt:


     

    VRM zeigt 5W an, dass BMS meldet aber 0 Ampere, dafür meldet aber der Lynx Shunt 0,1A was den 5W entspricht. Batteryaggregator zeigt auch 0.1A an jedoch gleichzeitig die 35% SOC vom BMS (der Lynx würde 0% melden).

    Die Spannung im Aggregator passt so nirgend hin - da die MPII noch aus sind - frag ich mich wo das nu schon wieder herkommt. OK das scheint der Mittelwert der BMS zu sein. Macht ja auch Sinn als "Aggregation". Dann könnte die Stromstärke dann die Summer der BMS sein. Da der Lynx keinen SOC meldet bleibt nur die 35% vom Seplos BMS - ok passt dann ja.

    Über die Zellen kann ich mich bisher nicht beschweren, 2mV differenz ist denke ich super im Messtoleranz bereich. Die Zellen sind nicht mals gebalanced, haben aber alle ~ die gleiche Energiemenge beim initialem Laden bekommen (alle einzeln).

    • New
    • Official Post

    Gerade mal eine Kleinigkeit an meinen MPII angepasst:

     

    AC Input auf 30A für alle MPII ändern (32A abgesichert). Ich gehe mal davon aus hier ist das pro MPII gedacht
    Und die PV Inverter Leistung erhöht (ist nur Kontrollwert - aber entspricht meiner aktuellen Realität)

    Der Prozess ist grob:

    1. Configure Bus öffnen
    2. Phase wählen
    3. MPII selektrieren
    4. VE Configure wählen
    5. Alte gespeicherte Config laden
    6. Änderungen vornehmen
    7. Alles senden (an diesen MPII)
    8. neue Konfig speichern
    9. Nächster MPII dasselbe Spiel
    • New
    • Official Post

    Super er lädt aus PV :)

    musste noch den Shunt aus der BatteryAggregator Summe rausnehmen

    root@einstein:/data/setupOptions/BatteryAggregator# pwd
    /data/setupOptions/BatteryAggregator
    root@einstein:/data/setupOptions/BatteryAggregator# cat config.json
    {
           "excludedServices": ["com.victronenergy.battery.socketcan_can0_vi0_uc288664"]
    }
    com.... ist das device (shunt) den dbus-spy ausspuckt

    und ich habe dann noch ein paar ESS Paramter angepasst

    z.B, dass er min 40% SOC hält und den Grid Setpoint auf 200W (hauptsächlich weil ich ja noch den SMA parallel betreibe) und der auf Null regelt - der soll aktuell priorität haben. Ob meine Logik stimmt - koine Ahnung :) Vermutlich eher nicht - mal schauen welches Gespann "gewinnt" solange nicht von einem Pack ins anderes und Zurück geschaufelt wird alles OK - der SMA kommt ja demnächst weg.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!