Voron 2.4 3D Drucker - Selbstbau Tagebuch

  • HIer mal ein paar Bilder um ein besseres Verständnis für die Größe des SMDs zu bekommen


       

    Ohne Mikroscope haben meine Ü50 Augen auf jeden Fall keine Chance


    Update: habe 0805 Bauform SMD bestell - tja selbst die sind wohl noch zu groß, jetzt 0603 1kOhm geordert - die müssen dann passen (hoffentlich). Also 0,6mm lang 0,3mm breit.

  •   


    Ich krieg hier gerade wieder nen Kabelkoller.

    WTF warum hat es den Mantel (ja die Adern stecken noch bombenfest gecrimpt) so zurückgezogen... Das letzte Silikonkabel (x/y Endstopp) tausch ich jetzt dann auch gleich mit aus. Dann sind alles was sich bewegt Helu 0.25 oder 0.5 Kabel. Ich kann Euch nur empfehlen nehmt Euch für die Geschichte echt ZEIT ZEIT ZEIT und macht es GLEICH ordentlich.

    Kabelsleeve tendiere ich mittlerweile dazu wenn dann nur einen etwas dickeren zu nehmen (oder gar keine), sonst tragen die sleeves zuviel auf um die an der Kabelbrücke vernünftig unterzubringen (ansonsten berührt der Kabelbaum immer die Z-Belts beim Homen). In der Kette selbst habe ich keine Sleeves, dort liegen die Kabel LOCKER drin.


    Der 4.7k SMD ist übrigens entlötet - war auch mehr Kampf wie sonstwas - ich hab zwar eine Entlötstation, aber das Teil war hier nicht zu gebrauchen, da einfach zuwenig Platz zwischen den Steckern und so richtig viel Lot gibt es ja auch nicht wegzusaugen. Am Ende dann den SMD bzw. die Kontakt richtig heiss gemacht und so dann runtergeschoben (nur mit der Lötspitze)

  • Da ich ja eh gerade wieder den halben Drucker auseinander habe - dachte ich mach ich doch gleich etwas gegen die verformte Bodenplatte.


       

    Von oben zwei Gegenhalter, von unten zwei weitere DIN Rails


    Auf die Scheine oben beim Netzanschluss kommen dann gleich die Wagoklemmen. Hoffe mal das funktioneirt wie gedacht - leider sind die unterschiedlichen Farben noch nicht da :( Alles in blau finde ich zu unübersichtlich sind immerhin über 30 Kabel. INteressanterweise passt meine Kabelführungslösung auf Basis der selbstgedruckten Energiekette ziemlich genau in die DIN Rail (siehe die untere Schiene).


    Der FI mit getrenntem Lastschutz wird ersetzt durch 6A Kombigerät (Amazon 16A Variante) welches auch nur eine Breiteneinheit nutzt. Ist recht teuer (50€) aber braucht halt nur ein Drittel des Platzes (die 10A Variente ist günstiger aber 10A sind mir zuviel - Amazon hat nur die 16A Variante).


    Die Anschlussklemmen (die blauen auf dem oberen Rail) sind Wago 2000-120x ala

    Die sollten mit den kleinen Aderendhülsen zusammenpassen.

  • Sodele es wird so langsam wieder mit den Anschlüssen...


    Kombi RCCD + LS und die Reihenklemmen sind jetzt drin. Die Aderendhülsen 0.25 passen gut - ist zu empfehlen. Die 0.5 gehen gerade so rein (sind die weissen).



     


    Jetzt dann noch von den Reihenklemmen wieder zu den SKRs. Und mein PT1000 oder SE450 fehlt noch damit ich gleich dem Tempsensor tauschen kann.

  • 1.8kOhm SMD ist drin - man habe ich geflucht.


    Das Board hat auch etwas gelitten - am Wochenende wird man dann wissen ob es noch funktioniert....

    Am meisten Probleme hatte ich damit die Temperatur vom "Löteisen" ins Lot zubekommen (das Zeuchs ist immer nur gelmäßig geworden). Groß mit Lot arbeiten geht ja auch nicht bei den kleinen Kontakten (0.3mm). Am Anfang hatte ich da einen richtigen Lotturm drauf und dann ist der SMD nicht mehr auf die Platine zubekommen.... naja war mein erster SMD und dann fast die kleinste Kategorie - ich emfehle es nicht! habe aber wieder was gelernt.

    • So der Drucker läuft wieder in anderen Sphären


    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Zum Mechanilk und Kabeltest ein paar Stunden. Alle halbe Stunde checke ich die Temperaturlinien und schalte mal Lüfter an/aus etc. Nur der Extruderstepper selber wird dabei nicht gestestet. Wenn der Testerfolgreich ist - kommmt als nächstes neuer Tempsensor rein und ich muss Z neu kalibieren, da neuer Z-Endpunkt (mit Haltenase damit der Stift nicht rausfallen kann beim Drehen).


    Anbei spheres350.zip die Gcode dazu - bitte vorsicht damit - er geht auf 340x340x301mm Bewegung (absolute koordinaten) - wenn was schiefgeht, rauscht der Extruder halt mal ins Bett .... sagt nicht ich habe Euch nicht gewarnt.


    Sind bei Euch die Z-Motoren auch so laut? (naja normalerweise laufen die ja kaum). max_z_velocity (15) habe ich noch auf standard - habe Videos mit settings Faktor 10 Höher gesehen, dann aber echt grenzwertig.


    Änderungen:

    • "Alles" auf Reihenklemmen - Bilder muss ich noch machen, aktuell sieht es aber noch etwas unordentlich aus.
    • Neuer Z-Endtopp
    • Neuer Partfan - der neue hat mehr leistung, grund war aber eigentlich, dass ich das sehr dünne Kabel beschädigt habe (ihr wisst ja mit Kabeln scheine ich es nicht so zu haben...)
    • MCU-Z mit einem Retail Bigtreetech 1.3 Board getauscht - einzige von außen sichtbare Änderunge -Namenslogo auf dem Board und Powerled ist rot statt grün
    • x/y Endstopp Silikonkabel durch Teflon getausch
    • Weitere LED Leitung zum xtruder verlegt (aber noch nicht in Betrieb)

    Kommt noch:

    • PT1000 ()1.8kOhm SMD ist in der MCU-Z oder SE450 Tempsensor
    • Probe evtl. durch eine 5er Variante tauschen - die ist ticken genauer geht aber def. nur mit non Alu heizbett.
    • Rückplatte aus Alucomposite - Bodenplatten habe ich denn wohl übrig - könnte ich abgeben (alu)
    • Türen mit verschraubten Schanieren (statt mit doppelseitigem Klebeband geklebt) - momentan habe ich die EInhausung weg
    • Z-Kabelkettenführung gefällt mir so auch noch nicht - muss ich auch mal ran.

    Aufgefallen - Firmware_restart geht jetzt wieder bei mir. Ging mit dem anderen MCU-Z board nicht - da war immer Stromaus angesagt. Zufall oder sind die Boards evtl. doch leicht anders....

  • Sodele ein Testscharnier montiert - total easy und das Ergebnis ist gut.


       


    • Das Acryl vorher mit dünnem Teslafilm abkleben (dann springt es weniger schnell auf und es gibt keine Kratzer/die Lochränder werden auch sauberer. Bohrer sollte auf jeden Fall scharf sein (eigentlich selbstverständlich) und eher schneller Bohren also nicht mit Schraubgang. Aber nicht so schnell dass das Acryl Euch davon schmilzt, mit leichtem Druck, bis saubere Späne kommen.
    • Nehmt idealerweise einen Bohrer mit Zentrierspitze (meist Holzbohrer), das macht es etwas einfach, aber es ist auch ein STL it einer Bohrschablone dabei, von daher kann hier kaum etwas schiefegehen bzgl. verrutschen. Durchmesser, so dass der Bohrer geradeso noch durch die Schablone passt. Ihr könnte aber auch kleiner vorbohren und dann die Zieldurchmesser ansetzen.
    • Evtl. müsst Ihr am Scharnier etwas material abschliefen damit es beim zumachen nicht hakelt (geht um zehntel), wenn Eur Bohrlöcher etwas Spiel erlauben sollte das schon reichen.
    • Beim Schraubenkopf (Aluextrusionsseite) müsst ihr mit einer Rundfeile (besser ist evtl. ein Dremel, wenn zur Hand - aber vorsicht das Acryl schmilzt schnell wenn Drehzahl hoch ist) in der mitte etwas material abheben, damit der Schraubenkopf sauber vorbeigeht. Evtl. die Scharniere montieren, Schraube durchstecken und die Stelle mit einem Marker vorher markieren.

    Anmerkung: die Scharniere sind auch etwas größer als die originalen, meine 3mm T-Nuts passten da nicht zwischen die Halternase für die Extrusions, daher musste ich eine Nase immer entfernen, hier nicht notwendig.

    Beim Original entfernte Nase

  • So Türen sind verschraubt und passen aufs Zehntel. Hält so weit gut - 2 Scharniere pro seite scheinen auch zu reichen. Kleben (mit Plastikkleber) ist aber sicherlich genauso gut - mein einziger Grund war, dass ich so mechanische Lösungen mit Verschraubungen einfach schicker finde (nicht immer einfacher).



    Seiten und Rückwanddichtungen sind durch 3mm Dicke getauscht - lasse ich jetzt erstmal setzen, dann kommen noch mehr Halter dran um das gleichmäßiger anzupressen. Oben lasse ich 2mm - kein technischer Grund da was zu ändern. Vorne mal schauen 2,5mm wäre eigentlich ideal :)

  • Heute mal Composite Alu platten von Fermio bekommen. Ich habe keine bisher eingebaut aber die Qualität sieht echt gut aus.


     

    sehr gute Schnittkanten und auch wirklich stabil im gegensatz zu reinen Acrylplatten.


    Kam jetzt für mich eigentlich zu spät - werde nur Rückwand und Bodendeckel verwenden. Wenn jemand interesse an der Platte auf denen die Rails motiert werden hat einfach bei mir melden - würde ich einzeln weitergeben (1/3 vom Set Preis). Idealerweise Umkreis Stuttgart, dann brauch ich das nicht versenden mit der Gefahr das es kaputt geworfen wird.

  • Z-Chain Guide



    Hab jetzt auf beiden Seiten eine Führung - habt Ihr das anders gelöst - reicht bei Euch eine Seite? Technisch reicht wohl eine, oder gar keine Führung - sieht aber schöner aus wenn es wirklich immer senkrecht steht.


    Ach ja bin gerade dabei mit einen Satz 4mm Panelhalter zu drucken. Die 3mm spannen zu viel und die 6mm sind zu locker. 4mm scheint ein guter Kompromiss. Hier

    midspan_panel_clip_4mm.zip die STL dazu. Die Ecken werde ich auch noch machen.

    Nachtrag die Ecken: corner_panel_clip_4mm.zip

  • Werde heute hoffentlich mal dazu kommen meinen 45Grad LED agnet Mount zu drucken und zu testen:


      


    Änderungen:

    • Front weiter heruntergezogen um Blendefekt zu verringern - leider ist dann nat. auch die Sicht auf Nozzle erschwert
    • 45Grad statt 25Grad Neigung für den LED Streifen - es sollte mehr auf Nozzel/HB fallen und weniger auf Buildplate

    Notiz: statt Filament verwendet ich ein Stückchen Teflonkabel zum Anhängen, das funktioniert ganz gut, Filament war bei mir etwas fummelig.


    Hotend_Fan_LED_45G.zip

  • Gerade mal den SE450 contra PT1000 getestet - zwei simple Temperaturmessungen


    Raumtemperatur (ca. 25C): PT1000: 25Grad, SE450 22Grad

    Kochendes Wasser: P1000: 100Grad SE450: 108Grad

    das war übrigens immer an default 4.7kOhm Pullup

    ==> ich nehme den PT1000


    Code
    ######### PT1000 1.8K #####################
    sensor_type: PT1000
    sensor_pin: z:P0.25
    pullup_resistor: 1800
    min_temp: 10
    max_temp: 350
    max_power: 1.0
    smooth_time: 3.0
    ######### PT1000 #####################


    Die Probe habe ich gerade auch getauscht von 08 auf 05:

     

    Dabei fiel mir auf die 08 hat schon einen starken Hitzeschaden vom Heatbreak


       

    Heatbreak hinten etwas Silikonisolierung und Probe reflektierende Folie


    ==> Isoliert die Probe an der Stelle, wo keine Heatbreaklüftung mehr hinkommt.


    Hier noch die Widerstandswerte für den SE450 falls den doch jemand verwendet:

  • So jetzt auch die Nozzle LED dimmbar angeschlossen:


       

    10%, 50% 100%


    Man sieht den Unterschied wohl eher nur wenn man die Umgebungshelligkeit berücksichtigt. Das Mobile dreht halt die Belichtung runter.

    Code
    [output_pin nozzlelight ]
    # Nozzle Lighting - Bed Connector (Optional)
    pin: P2.5
    pwm: true
    shutdown_value: 0
    value: 0
    cycle_time: 0.01
    scale: 100
    Code
    [gcode_macro NOZZLE_ON]
    gcode:
    M117 Switch lights on
    SET_PIN PIN=nozzlelight VALUE=100
    
    [gcode_macro NOZZLE_OFF]
    gcode:
    M117 Switch lights off
    SET_PIN PIN=nozzlelight VALUE=0




     

    Man bekommt auch einen 350er voll :(

    Raum abgedunkelt - nur LEDs vom Voron.

  • Sodele heute morgen mal Inputshaping....


    Wozu input shaping? Schaut euch mal einen meiner letzten Drucke an:



    Da seht Ihr schön den Ringing oder auch Ghosting effekt. Sprich die Kante ist im Druck noch x mal zu erkennen. Dieser Effekt soll durch Inputshaping reduziert werden. Wichtig dabie ist, dass die Tests so ausgeführt werden wie der Drucker im Betrieb auch steht. Es werden Resonanzen gemessen, d.h. Standort, Riemenspannungen etc. haben hier einen großen Einfluss. Ändert Ihr etwas am setup - müsst Ihr die Messung nochmals machen.


    https://www.klipper3d.org/Measuring_Resonances.html

    Das Video dazu:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Das ganze ist in < einer Stunde umzusetzen und erfolgt in vier Phasen:

    1. Hardwarebuild - Platine + Kabel
    2. Softwareinstallation auf dem PI
    3. Anschrauben und laufen lassen
    4. Auswerten

    Hardware:

    Das Bord selber ist echt nicht teuer und für 6€ auf Amazon erhältlich.

    Die Stiftleiste einlöten ist easy - am meisten Zeit braucht dann das Kabel. Ich habe hier 4x4er Buchsen genommen. Wobei ich 2 davon zu einer 8er zusammengeklebt habe. Evtl. habt Ihr die ja von Euren Steppermotoren übrig (7 Stück solltet Ihr ja haben).


    Abstandshalter 8er Stecker und 2x4 zu einem 8er verklebt


    Als Kleber den Pattex (danke an Gerd für den Kleberhinweis). Damit Ihr Euch keinen abbrechen müsst beim PIN zählen nehmt einfach einen 8er Stecker. Oben und unten sind je 8 Pins frei.



    Das dann so verkabeln:


    Hochprofessionelle Zeichnung der Verkabelung


    Sofwarebuild - lest Euch die Doku durch - ist alles Schritt für Schritt in https://www.klipper3d.org/Measuring_Resonances.html erklärt.


    Dann montieren:

    Ich habs vorne montiert.


    Ich habe den Sensor vorne montiert - war am einfachsten umzusetzen. Vermutlich ist direkt am Carriage aber einen Ticken genauer.


    Ergebnis:


    X und y - vorsicht y-Achse ist Z im Bild (wegen der Montage des Sensors)


    Mein X hat leider aktuell 2 Frequenzen :( jetzt wählt dann mal Pest oder Cholera. Ich wähle mal 45Hz MZV. Vermute mal das liegt daran, dass der Drucker noch auf dem Basteltisch steht.

    Mein Y hat eine bei ca. 32Hz MZV (vorsicht die Analyse sagt was anders, aber die wertet halt die falsche Richtung aus). Ich wähle hier MZV um den Smoothing effekt für die Kanten zu reduzieren (sm Wert im Graph). Ihr könnte den Graph aber auch mit einer entsprechende sm Vorgabe produzieren (steht in der Anleitung).


    Jetzt noch das Ergbnis in Eure printer.cfg übertragen:

    Code
    [input_shaper]
    shaper_freq_x: 45
    shaper_type_x: mzv
    shaper_freq_y: 32
    shaper_type_y: mzv

    Macht am besten ohne und mit inputshaper ein paar entsprechende Ghosting test prints und damit dann auch die max acceleration zu finden die Euch noch passt (10000 wird vermutlich zu hoch sein und nur für die Messung zu verwenden).


    Quote

    TUNING_TOWER COMMAND=<command> PARAMETER=<name> START=<value><br>FACTOR=<value> [BAND=<value>]: A tool for tuning a parameter on each Z height during a print. The tool will run the given COMMAND with the given PARAMETER assigned to the value using the formula value = start + factor * z_height. If BAND is provided then the adjustment will only be made every BAND millimeters of z height - in that case the formula used is value = start + factor * ((floor(z_height / band) + .5) * band).

    TUNING_TOWER COMMAND=SET_VELOCITY_LIMIT PARAMETER=ACCEL START=1250 FACTOR=100 BAND=5 (im DE Excel is floor Untergrenze als Funktion)<br>

    Ergibt dann 1500 und alle 5mm 500 mehr an Beschleunigung.
    Anmerkung: Wenn Ihr auf niedrige Ströme optimiert habt, müsst Ihr diese für hohe Beschleunigungen vermutlich wieder raufsetzen, zumindest hat bei mit ab 6000 dann der Stepper nicht mehr wirklich folgen können.


    Bitte wie immer, falls ich hier irgendwo Käse geschrieben habe mit mitteilen. Die manuellen Tests und Vergleiche mache ich noch - sprich zur Wirkung kann ich noch nichts aus eigener Erfahrung schreiben.


    Edit 2021-04-02:

    Heute nochmals nachgemessen (Drucker auf einem festen Standplatz):

    Code
    [input_shaper]
    # 2021-04-02
    shaper_freq_x: 73.4
    shaper_type_x: zv
    shaper_freq_y: 47.6
    shaper_type_y: mzv

    Frequenzen sind deutlich höher, was eigentlich gutes Zeichen ist.

  • Testprints done F.CK was für ein Unterschied...


    Druckabbruch ohne Shaping und 650mA Strom


       

    Das Ganze dann nochmals mit 800mA


     

    Und mal mit Beschleunigswerten

    Ab 4500mm/ss wird das Ringing echt deutlich ab 6000 ist die Kante als kaputt zu bezeichnen. Das X ist ab 5x auch sehr deformiert.


    Jetzt mal der Vergleich:


       


    Der Unterschied ist so krass, dass ich gerade daran zweifel ob die Beschleinigung erhöht wurde....? Vom zuhören her würde ich sagen ja, optisch ist aber nichts nada zu erkennen.


    Ich mach den Testprint nochmal mit Photo vom Towerkommando....

    Druck läuft


    Druck fertig und gleich gutes Ergebnis -> jetzt drucke ich mir mal ein größeres nicht Testobjekt (den Qidi Extruder) um zu vergleichen.

  • Heute nochmals nach meinem Probeabstand wechsel dich Problem geschaut, da ich eh noch die Isolierung vernünftig machen wollte.

    Hier das Klebeband, dass jetzt dran ist: 5 Meter Rolle selbstklebend hitzeisolierend golden bis 450°C



    Und ich denke "Asche auf mein Haupt", die Schrauben der Probe waren nicht ordentlich fest. Hatte die wohl leicht lose um den Abstand optimieren zu können. Jetzt ist es fest - mal schauen ob es nun auch immer den gleichen Abstand gibt. Zumindest wird so ein Schuh draus - und ich steh wie ein begossener Pudel :( Naja Problem identifiziert und hoffentlich auch gelöst.

  • Heute nur zwei kleine Dinge:

    Top Layer Qualität mit SuSl und ABS "Gold" 0.2mm + 0.4er Nozzle100mm/s


    Speedtests gehen ab ca. 125mm/s und dem Standard Dragon schief - kommt zu Aussetzers im Vorschub. mit extremen Übertermp geht es so lala. Sensor zeigt aber konstante temp an.

    mal als 110mm/s würde ich mit einem standard Dragon also nicht drucken. Highflow habe ich da werde mir wohlen einen zweiten Extruder zum Wechseln bauen.


    Noch einen kleinen Chainguide konstruiert, da meine Energiekette tendenziell immer vom der Extrusion gerutsch ist

    Nicht wirklich runter, aber immer schief drauf lief. STL: Guide.zip


    Kann man siecher schöner machen - ist eher als Test zu sehen.

  • Neuer Arbeitsplatz des Vorons fertig - 3cm Leimholz mit der Wand verschraubt und drüber eine 59.5x59,5cm Bodenfliese damit die Standfläche schön eben.



    Eine Terassenfliese statt dem Holz wäre zwar besser aber oberhalb der Tragkraft meines Regals.

  • Falls es Interessiert hier noch meine OctoPi Ansichten. Ja da bin ich noch classic, andere fluchen mittlerweile auf die vielen Plugins und Co. Ich finde es durchaus interessant immer mal was neues auszuprobieren.




       



    Was ich jetzt eigenlich noch suche sind customizable controls zum Exhaust Fan und LEDs ein/aus oder dimmen. Ich habe zwar das Enclosure Plugin gefunden aber das geht über den PI, ich würde das gerne über Gocde/Klipper (aber nicht via Terminal) machen - aber gut evtl. habe ich da was überlesen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!