Posts by Gerd

    Probe-Offset:

    Ich habe den bei mir 'fest' eingestellt, da ich mit dem 'automatischen' Paper-Test auch nicht klar gekommen bin.

    Fahre die Z-Achse von Hand auf 1 - 0,5 - 0,1 ... runter - Papier drunter - und Ergebnis in der config korrigiert.


    [probe]

    # z: bei zu großem Nozzelabstand, den Wert um diesen Abstand erhöhen

    z_offset: 5.4

    Danke für Eure Bemühungen zum D500 :-)

    Die Einzigen die den scheinbar bisher zum Laufen gebracht haben, verwendeten die

    [thermistor dyze500] Config mit nur 3 Werten - scheint mir zu ungenau.

    Da ich aber die komplette Widerstandtabelle hier habe, wollte ich die natürlich

    mit [adc_temperature xxx] (sind bis zu 1000 Einträge möglich ;-) verwenden.

    Ist aber nicht so einfach...

    Solange man vernünftige R-Werte für 0°C verwendet wird bei Zimmertemperatur

    immer ein Wert von -4000 bis -2000°C ausgelesen (im Display noch angezeigt)

    und dann steigt die MCU mit ADC-Fehler aus.

    MIN-TEMP läßt sich in der Config leider nur bis -273°C einstellen.

    Dummerweise kann man dann ja nicht mal mehr den ADC-Wert vom Klipper auslesen.

    Den Widerstand vom Sensor habe ich natürlich kontrolliert - ist alles ok.

    Habe im Quellcode auf die Schnelle nix gefunden, warum das so ist - vllt. ist einer schlauer.

    Als Workaround habe ich jetzt einen 0°C Eintrag mit mit R=1GOhm (1.000.000.000) verwendet,

    damit liegt die Starttemperatur knapp über 0°C.

    Nun kann man wenigstens mit der MCU reden :-)

    Tests mit Widerstandswerten für 100, 200, 300, 400, 500 °C sahen dann auch sehr gut aus (waren also exakt).

    Praktische Messungen mit einem digitalen 'Bratenthermometer' (mit Wärmeleitpaste an der Verschraubung Thermistor)

    haben dann auch eine relativ gute Linearität zwischen 100-250°C gezeigt (dann steigt leider das Thermometer aus).

    Inwieweit das gemessene absolute Delta von ca. 10°C dem 'Meßaufbau', dem Thermometer oder der Kennlinie geschuldet sind

    kann ich jetzt noch nicht sagen.

    Zum einfachen korrigieren und kontrollieren der Kurve habe ich eine XLS erstellt, aus welcher man dann die

    Config-Werte per c&p einfach in der richtigen Syntax übernehmen kann.

    Hat jemand den (Thermistor am Hotend) SE450 oder D500 oder etwas ähnliches (8K@200°) verbaut

    und mit [adc_temperature XXX] in der config erfolgreich konfiguriert?

    Ich bekomme nur ADC-Out-of-Range - egal was ich konfiguriere :-(

    Blöderweise kann man über Octo nach so einem Fehler nicht mehr mit Klipper kommunizieren und die ADC-Werte abfragen, weil der die MCU tot legt - möchte mal wissen wozu dies gut sein soll - grrr.

    @Olaf: CF-PC - Sehe gerade, daß ich meine vorigen Kommentare in den Bauthread gesteckt habe - Tschuldigung :-(

    Kannst vllt. hier her verschieben - oder löschen.

    Habe auf die Schnelle nur einen alternativen Anbieter für CF-PC (>100€/kg) in D gefunden und nun bei A.com für 63€

    (inkl. Versand+Steuern) aus den USA? liefern lassen.

    Druckst Du mit ner 0,4er Düse? gehärtet?

    @Olaf: Z-Endstop mit Probe:

    Meine Arbeiten am Drucker ruhen z.Z. immer noch, da die anderen Baustellen noch nicht fertig sind... :-(

    Aber bei allen bisherigen Drucken hatte ich keine Probleme mit der Probe.

    Habe allerdings auch noch keine low-temp Filamente gedruckt um die Unterschiede in der Kal. zu testen.

    Kenn jemanden der hat sich eine temp-kompensierte bestellt, aber ist noch nicht beim Testen.

    Was die Plate betrifft, gegen welchen Typ willst Du denn tauschen, daß Du so große Unterschiede erwartest?

    Bei allen meinen Kästen werden die Schilder nur von oben eingesteckt.

    Fixierung nur unten und seitlich (reicht), ist nicht so ein 'Gefriemel' beim tauschen bzw. ergänzen.

    Vllt. ließe sich das mit einem in die Wand integrierten Einschub von schräg oben versuchen,

    so das die Vorderseite sozusagen plan bleibt.