Voron 2.4 Selbstbau - Diskussionen- und Kommentarethread

  • Er geht in den Notshutdown und faselt was von Temperatur Abweichung.


    Im Superslicer habe ich das Voron PLA Profil benutzt. Sonst keine Änderung. Ich habe jetzt mal die Filament Einstellungen für die Kühlung halbiert. Bisher druckt er weiter.


    Das einzige was ich mir vorstellen könnte, dass aufgrund fehlender Wärmeleitpaste bei Thermistor und Heizpatrone das Problem auftritt. Zumindest liest man an verschieden Stellen, dass man das machen sollte. Jedoch gibt es im Assembly Guide von E3D keinen Hinweis darauf. Daher habe ich es bisher auch nicht gemacht.

  • Das mit dem Notshutdown ist korrekt, wenn er versucht zu heizen aber die Temperatur nicht entsprechend gehalten wird oder steigt.

    Wärmeleitpaste glaube ich nicht - die habe ich manchmal dran manchmal nicht, das macht nicht so dramatisch viel aus (wenn die Heizpatrone sonst richtig geklemmt ist).

    Das der Lüfter die Temperatur so runterzieht kann ich auch irgendwie nicht so recht glauben - ich habe hier auch schon mit 100% FAN eine Weile gedruckt.


    Hast due 40,50 oder 60... W Heizpatrone?


    Für mich sieht das eher nach Stecker oder Kabel aus, natürlich schwierig da eine remote Diagnose zu stellen.

  • Ehrlich gesagt kann ich dir das gerade nicht sagen. Habe ein Kit bei 3dJake gekauft. Hier der Link: https://www.3djake.de/e3d/v6-a…nd-bowden-175-mm?sai=7348

    Ich finde leider bei E3D auch nichts genaues. Habe nur eine Auflistung gefunden für rote und blaue Leitung. Jedoch hat meine Patrone gelbe Kabel :wacko:

    P\V12v 24v
    40w (Red Leads) 3.6Ω 14.4Ω
    25w (Blue Leads) 5.76Ω 23.04Ω
    30w (Blue Leads) 4.8Ω 19.2Ω


    Die Heizpatrone ist momentan gekürzt und am Extruder mit 0.5 Heluflon Kabeln verlötet. Am SKR ist das Kabel direkt angeschlossen und die Kabelenden sind mit Aderendhülsen geschützt. Der Thermistor ist per Stecker verbunden. Habe ich aber schon geprüft. Kein Wackelkontakt.

  • Wenn es der Thermistor wäre müsste die Temp recht plötzlich springen - so wie ich Dich verstanden habe, fällt sie "nur" recht schnell aber nicht schlagartig. Stecker bei der Heizpatrone können wir also wohl eher ausschließen, wenn Du verlötet hast. Kabel Helufon - dass die auch brechen können, habe ich ja an meinem Stepperkabeln gemerkt. Bei mir war vermutlich ein Knick im Kabel und an der Stelle ist dann gebrochen. hatte aber eine Weile gehalten und dann gab es sporadisch je nach Position des Extrudes Aussetzer bis zum Totalausfall.


    Standard E3D Heater hat 30W. Du könntest (wenn Du hast) ein Ohmmeter am Ende (beim Board) anschließen und mal den Widerstand messen auch bei Bewegung des Extruders und schauen ob der konstant bleibt. Wenn der springt wäre doch das Kabel am Popo.


    Du hast ja auch geschrieben - ohne/50% lüfter lief er - hast Du fertig drucken können? Wenn es am Lüfter liegt müsster er auch im Stand wenn du nur Filament extrudierst (möglichst schnell) und den Lüfter auf 100% stehen hast abkühlen. Wenn im Stand aber alles stabil bleibt muss es ja etwas mit der Bewegung zu tun haben - würde ich mal Schlussfolgern... ?

  • Ich drucke schon seit Tagen nur mit Z-Probe-Endstopp - bin zufriede

    Gerd immer noch zufrieden? Bin kurz davor auch von dem mechanischen Endstopp wegzugehen. Ich muss nur auch mal testen, wie sich ein Wechsel der Printplate auswirkt. Idealerweise sollte keine z_offset Änderung nötig sein, aber das würde nur funktionieren, wenn die Probe auf das Bettmaterial immer gleich reagiert. Ich befürchte das wird leider nicht so sein.

  • Problem gelöst, Habe die Heizpatrone gegen ein 40W Version getauscht. Nun treten die Probleme nicht mehr auf.

    Bah - wenn es wirklich an der Patrone lag würde ich 3djake mal anpingen - der Preis von dem Teil ist ja eher hoch gewesen.

  • An dem Z-Homing mit der Probe bin ich auch interessiert, wo kann man dazu mehr lesen? Wenn man bei Octoprint/Mainsail ein passendes Preset

    Im Prinzip - muss Du nur statt dem connect PIN virtual endstop in die config schreiben und eine Probe Calibration durchgeführt haben (z-offsett muss stimmen). Bin leider gerade nicht am Rechner sonst würde ich das hier kurz reinpasten, Aber such einfach mal nach virtual endstop und/oder Probe Calibration.

  • Im Prinzip - muss Du nur statt dem connect PIN virtual endstop in die config schreiben und eine Probe Calibration durchgeführt haben (z-offsett muss stimmen). Bin leider gerade nicht am Rechner sonst würde ich das hier kurz reinpasten, Aber such einfach mal nach virtual endstop und/oder Probe Calibration.

    Würde mich auch interessieren

  • Ist im Prinzip einfach - fangt erstmal mit einem

    Code
    PROBE_ACCURACY

    Kommando an dann kommt so etwas:

    Wichtig ist dabei, dass Ihr das an einer Referenzstelle am Bett macht (typischerweise nach dem Home). Und Bitte bei Z-Einstellen immer G28, QGL,G28,QGL,G28 und dann erst loslegen. Die Position nach dem ersten G28 ist fast immer falsch, da das Gantry noch nicht ausgerichtet ist. Beim zweiten sollte es schon richtig sein, aber so what alle Guten Dinge sind drei.


    Der Accurancy Befehl checkt nur ob die Werte insich konsisten sind - also von Messung zu Messung nicht abweichen. Aber das kann schon mal locker 1-2 Zehntel schwanken je nach dem wie die Temperaturen sind - also bitte auch immer bei den temperaturen kalibrieren, bei denen Ihr später auch druckt. Bei meinen 110C Bett hat die Nozzle schon >50Grad ohne das Patrone an ist oder war. Entsprechend heiß wird die Probe und das kann das Ergebnis verfälschen.


    Wenn die Genauigkeit passt macht Ihr ein:

    Code
    PROBE_CALIBRATE

    siehe auch: https://www.klipper3d.org/Probe_Calibrate.html

    Weiter wie beim normalen Endstop mit TESTZ soweit runter, bis das Papier sich gerade rau bewegen lässt.


    dann speichern

    Code
    Send: SAVE_CONFIG
    Recv: ok
    Recv: // Klipper state: Disconnect
    [...]
    Recv: // Klipper state: Ready

    jetzt steht der Wert unten in der printer.cfg

    Code
    #*# <---------------------- SAVE_CONFIG ---------------------->
    #*# DO NOT EDIT THIS BLOCK OR BELOW. The contents are auto-generated.
    #*#
    #*# [stepper_z]
    #*# position_endstop = 3.82
    #*#
    #*# [probe]
    #*# z_offset = 1.650

    position_endstop ist also der Wert für den mechanischen Endstop und z_offset für die Probe. Also quasi der Abstand der Nozzle zum Bett wenn die Probe auslöst.


    Teil eins done - und somit die Vorraussetzungen geschaffen.

    BTW:

    • Alles ohne Garantie, obiges ist mein Verständnis korrekturen sind definitiv erwünscht - Ihr arbeitet auf eigenes Risiko!
    • Die Probe muss natürlich zuverlässig sein und reproduzierbare Ergebnisse bringen, sonst geht das in die Buxe
  • Teil Zwei in Betrieb nehmen der Probe als Z-Endstopp:


    Zwei Dinge:

    Code
    [stepper_z]
    #endstop_pin: z:P1.25
    # in case the probe should be used
    # Then take care (MUST!!) that z_offset is set correctly
    # means PROBE_CALIBRATE is properly done before
    endstop_pin: probe:z_virtual_endstop

    also umstellen auf die Probe - alten Pin auskommentieren. UND WICHTIG - die Z-Home Position muss in der Mitte des Betts sein nicht mehr hinten beim Stift!!!!!


    Also so etwas: (175,175 ist beim 350 die Mitte)

    Code
    [safe_z_home]
    home_xy_position: 175,175
    speed: 50
    # Distance to bed after homing
    z_hop: 30
    z_hop_speed: 5

    Das war's im Prinzip. Auch ja safe_z und homing_override geht nicht zusammen und Klipper wird nicht wieder starten.


    Und immer schön den Finger auf dem Emergency stop :)

  • Alternative section mit Homing override:

    https://www.klipper3d.org/Conf…ence.html#homing_override

    Am Ende sollte M114

    Code
    Send: M114
    Recv: X:175.000 Y:175.000 Z:30.000 E:0.000
    Recv: ok

    ergeben und wenn Ihr auf 0 runterfahrt auch wirklich auf null sein nicht im Bett - testet dass sicherheitshalber auch mal vorsichtig.

  • @Olaf: Z-Endstop mit Probe:

    Meine Arbeiten am Drucker ruhen z.Z. immer noch, da die anderen Baustellen noch nicht fertig sind... :-(

    Aber bei allen bisherigen Drucken hatte ich keine Probleme mit der Probe.

    Habe allerdings auch noch keine low-temp Filamente gedruckt um die Unterschiede in der Kal. zu testen.

    Kenn jemanden der hat sich eine temp-kompensierte bestellt, aber ist noch nicht beim Testen.

    Was die Plate betrifft, gegen welchen Typ willst Du denn tauschen, daß Du so große Unterschiede erwartest?

  • Was die Plate betrifft, gegen welchen Typ willst Du denn tauschen, daß Du so große Unterschiede erwartest?

    Ich habe hier verschiedenste von Energetic (rauh und glatt) und auch eine von Trianglelabs die ist eher Pulverbeschichtet. Ich werde es einfach ausprobieren. Jetzt muss ich erstmal den richtige zoffsett ausknobeln damit der first layer wieder wird.

  • Kurzer Nachtrag zum z_offset von oben. Gemessen hatte ich ja 1.65mm Abstand beim Probe_calibrate. EIngestellt habe ich jetzt 1.88mm und damit habe ich jetzt zwei prints erfolgreich gemacht. Heisst - Ihr müsste den Wert nach der Kalibrierung vermutlich durch eine paar Firstlayertestprints noch optimieren.

  • Hi,


    Mein Voron_2.4_300 arbeitet nun mit der SuperPinda. :)

    Die Diode habe ich drin gelassen. Das sollte ja kein Problem sein. Wichtig ist nur, dass man die Stromversorgung von 24V auf 5V ändert. Gibt auf den SKR's ja einige Stellen ;)

    Beim Einbau habe ich die Pinion.stl verwendet. Das Teil schliesst unten mit dem Carriage ab. Die Position der SuperPinda habe ich wie folgt durchgeführt:

    1. Gantry soweit runter geschoben (von Hand), dass die Düse das Bett (inkl. Federstahlplatte) berührt
    2. Danach braucht ihr einen üblichen Kabelbinder und schiebt diesen unter die SuperPinda
    3. Dann den vorderen Teil des Extenders und den Hotendhalter entfernen
    4. Nun die SuperPinda nach unten schieben, bis sie den Kabelbinder berührt
    5. 3 und 4 wiederholen bis es passt
    6. SP festschrauben

    HINWEIS: achtet darauf, dass die SuperPinda zuverlässig arbeitet. Nutzt hier zum Beispiel den Befehl QUERY_PROBE

    Ich weiß , dass das etwas fummelig ist, aber es funktioniert.


    Danach habe ich die oben beschriebenen Schritte durchgeführt. Vielen Dank nochmal an Olaf :)


    Der erste Druck sieht sauber aus und nun gibts keine Sauerrei mehr auf dem Endstop Pin :love:

  • Anmerkung Mod - Verschoben : Beitrag bezieht sich auf: RE: Voron 2.4 3D Drucker - Selbstbau Tagebuch


    Hi, für die Heizbett-Isolierung gibt es noch andere Lösungen.

    Zum Beispiel:

    Isolierung mit ALU

    oder

    Isolierung aus Kork


    Das sind jetzt nur 300x300. Gibt es sicher auch größer. Der Vorteil hier wäre, dass das ganze unten festgeklebt werden kann. Somit hat man auch einen weiteren Schutz vor dem abfallen des keenovo Teils.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!